Status code 500 when serving model locally


I have successfully installed hopsworks as a vagrant VM locally.

Wanted to test the model serving functionality, but got a 500 server error code.
I suspect there is some logic incompability in the glassfish server code when running model serving locally, because i tried using the hops.util library to do POST request to glassfish and got 500 returned.

Appreciate any recommendation. Thank you

Hi, what version of hopsworks are you using?

Hi, i am not quite sure where i can check the version
but i got it from git clone just 1 week ago, so i guess should be the latest

Hi @leekeonshin!

Then it seems like you are installing the latest development version which is 1.4.0-SNAPSHOT. Are you trying to serve a TensorFlow or SkLearn model?

Hi, I am trying to serve a sklearn model. Even the iris example also gave the same error code 500 when i tried to start serve

Hi @leekeonshin! Another user encountered the same issue recently. You can find the solution here: Permission denied when serving We are making the 1.4.0 release soon in which serving will be working properly for SKLearn and TensorFlow.

Best regards,

Thanks @Robin_Andersson. I tried to do the modification in as well as but the error still persist.
I guess it may be a different issue because for my case, i cannot see anything in the Kabana logs unlike the user