Singleton StagingManager unavailable + more bugs


First of all, congrats for the platform and the concept of the feature store! I like it, even though it isn’t easy to understand at the beginning.

This last weeks i had several problems with the platform when uploading data.

  1. When i upload the data in the feature groups many times it keeps hanging the connection, until i have some timeout. Mainly it happens when uploading the Dataframe. I share screenshots run on
  • IN the next i add the photo 1
  1. When uploading large models or photos (a photo of the predictions in the inference offline pipeline) to hopsworks I get many times this error:
  • In the next i embed the photo 2
    The main problem I have is that with photos sometimes doesn’t work (like how i show in the photos). In the case of the photos i use for example:
dataset_api = project.get_dataset_api() 
dataset_api.upload("./scatter_plot.png", "Resources/images", overwrite=True)

In the case of the model is even worse, as i can never upload it. I attach the model uploaded in huggingface:

I literally always throws the same error. In that case i use the following commands:

mr = project.get_model_registry()
hopsworks_model = mr.python.create_model(
        description="My model"
import pickle
pickle.dump(model_1, open("model.pkl", "wb"))"model.pkl")

It would awesome if you could add some indicative errors logs such what I am doing wrong or anything, because this current errors doesn’t show what i am doing wrong, if i am doing something wrong.

Thank you!

Photo 1

Photo 2

+1, I’m running into the same error while trying to upload to the model registry. I think it’s connected to the action of uploading somehow? I was able to access some feature groups and feature views just fine.