Is "FileSize" a reserved word?

When I tried to create a new DATASET, I ran into an interesting problem. The name of the new DATASET is “FileSize”, when I selected option “Everyone can read”, the new DATASET was able to be created correctly, but when I selected option “All Data owners can edit”, the new DATASET could not be created, as shown in the screenshot below:

I guess that “FileSize” might be a reserved word, but I don’t understand why the new DATASET can be created when I select option “Everyone can read”. Where can I find the instructions for the HOPSWORKS reserved words? BTW, I’m using version 2.0.

Hej @Freeman,

FileSize should not be a reserved word. There must be another issue with the dataset creation.
Can you follow the logs under:
And check the exact error you get when creating this dataset.
You can find reserved project names:
and reserved dataset names:


Hi @Alex ,
Thank you for your reply, I will check the server.log and reply to the relevant information in this post.