Installing Hopsworks using cloud installer always installs master version (2.0.0) instead of wanted 1.4

Dear all,

we are currently installing Hopsworks in Azure using the cloud installer. When we start the installation with “wget” expecting to get version 1.4.X of hopsworks. But after creating a demo projects we see in settings/versions that we got 2.0.0-SNAPSHOT. How can we ensure that v1.4 gets installed?

Note: The wget command inside the documentation ( fails - there is a “/cloud” missing after “…/1.4”.

Bonus question: If we go with 2.0.0 - is there a suitable python package for “hops”? Because the documentation states that “YOUR_HOPSWORKS_VERSION needs to match the major version of Hopsworks”.

Many thanks and best,
Roberto Rösler


Thank you for reporting the documentation error, it is now fixed.

We will have a look into why the installer installed snapshot instead of 1.4. Since snapshot was installed, that means latest hops python library was also installed. It is fine to keep on working with the snapshot instance, you can try running one of the notebook examples in the feature store or deep learning tours to make sure the hops python library is working ok.

Hi Theo,

thanks for the answer.

What we want to test is the connection with Databricks. The documentation states that the hops package have to match with the installed Hopsworks instance with the major version. But I don’t see a 2.0.0 on github or pypi. Latest is So the installed snapshot will not match with the hops package installed in databricks. Thats why we tried to install a 1.4.X version.
Can this be solved?

Many thanks and best, Roberto

Hi Roberto,

When Hopsworks master/snapshot is installed, then master branch of hops and hsfs is installed but the actual version is not updated until the release is done. So it should work the same to connect to Databricks for your instance. If you get any compatibility issues let us know, then it might be necessary to re-install to get the 1.4 version.