Hopsworks 2.4 Install failure on conda::default


I’m getting this error when trying to install hopsworks 2.4

cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++ [enabled by default]
gcc -pthread -B /srv/hops/anaconda/anaconda/envs/hops-system/compiler_compat -Wl,–sysroot=/ -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -Isrc/sercore/HadoopUtils -I/srv/hops/anaconda/anaconda/envs/hops-system/include/python2.7 -c src/sercore/HadoopUtils/SerialUtils.cc -o build/temp.linux-x86_64-2.7/src/sercore/HadoopUtils/SerialUtils.o -Wno-write-strings -std=c++11 -O3
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++ [enabled by default]
g++ -pthread -shared -B /srv/hops/anaconda/anaconda/envs/hops-system/compiler_compat -L/srv/hops/anaconda/anaconda/envs/hops-system/lib -Wl,-rpath=/srv/hops/anaconda/anaconda/envs/hops-system/lib -Wl,–no-as-needed -Wl,–sysroot=/ build/temp.linux-x86_64-2.7/src/sercore/hu_extras.o build/temp.linux-x86_64-2.7/src/sercore/sercore.o build/temp.linux-x86_64-2.7/src/sercore/streams.o build/temp.linux-x86_64-2.7/src/sercore/HadoopUtils/SerialUtils.o -L/srv/hops/anaconda/anaconda/envs/hops-system/lib -lpython2.7 -o build/lib.linux-x86_64-2.7/pydoop/sercore.so
WARNING: log4j.properties is not found. HADOOP_CONF_DIR may be incomplete.
ERROR: JAVA_HOME is not set and could not be found.
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-install-1nNI7E/pydoop/setup.py”, line 368, in
File “/srv/hops/anaconda/anaconda/envs/hops-system/lib/python2.7/site-packages/setuptools/init.py”, line 140, in setup
return distutils.core.setup(**attrs)
File “/srv/hops/anaconda/anaconda/envs/hops-system/lib/python2.7/distutils/core.py”, line 151, in setup
File “/srv/hops/anaconda/anaconda/envs/hops-system/lib/python2.7/distutils/dist.py”, line 953, in run_commands
File “/srv/hops/anaconda/anaconda/envs/hops-system/lib/python2.7/distutils/dist.py”, line 972, in run_command
File “/srv/hops/anaconda/anaconda/envs/hops-system/lib/python2.7/site-packages/wheel/bdist_wheel.py”, line 188, in run
File “/srv/hops/anaconda/anaconda/envs/hops-system/lib/python2.7/distutils/cmd.py”, line 326, in run_command
File “/srv/hops/anaconda/anaconda/envs/hops-system/lib/python2.7/distutils/dist.py”, line 972, in run_command
File “/tmp/pip-install-1nNI7E/pydoop/setup.py”, line 320, in run
File “/tmp/pip-install-1nNI7E/pydoop/setup.py”, line 301, in build_java
jb = JavaBuilder(self.build_temp, self.build_lib)
File “/tmp/pip-install-1nNI7E/pydoop/setup.py”, line 199, in init
self.java_libs = [JavaLib()] File “/tmp/pip-install-1nNI7E/pydoop/setup.py”, line 183, in init
self.classpath = pydoop.hadoop_classpath()
File “pydoop/init.py”, line 79, in hadoop_classpath
return _PATH_FINDER.hadoop_classpath()
File “pydoop/hadoop_utils.py”, line 126, in hadoop_classpath
“hadoop classpath --glob”, shell=True, universal_newlines=True
File “/srv/hops/anaconda/anaconda/envs/hops-system/lib/python2.7/subprocess.py”, line 223, in check_output
raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command ‘hadoop classpath --glob’ returned non-zero exit status 1

It looks like JAVA_HOME is not set, but I’m not sure. JAVA_HOME is set in my environment and I get this same error if I try to run the chef recipe directly. I’m trying to install on an AWS EC2 instances running CentOS 7.

Hi @gil,

Are you installing Hopsworks using the cloud installer or using Karamel?
The recipes will try to install Java before running. Is JAVA_HOME set for the anaconda user as well?

Hi @gil. Can you tell us the centos version minor number (you mentioned it is version 7)?
JAVA_HOME is set at the beginning of the conda::default recipe, so i suspect the problem is something else. Is this server behind a firewall?

This is the CentOS version
CentOS Linux release 7.9.2009 (Core)

I’m not sure if it’s behind a firewall. It’s an aws ec2 instance but it doesn’t have a public ip. It was able to compete a things up to this point without any proxy settings. If I run the chef command directly ( sudo chef-solo -c /home/ec2-user/.karamel/install/solo.rb -j /home/ec2-user/.karamel/install/conda__default.json) I get the same error

Also if I su to anaconda user JAVA_HOME is set