Hopsoworks Python(3.9) Installation Error

While trying to install Hopsworks in a Python 3.9 environment, I get the following error:

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
nbconvert 7.2.9 requires mistune<3,>=2.0.3, but you have mistune 0.8.4 which is incompatible.

How can I deal with this error?

The error is showing you that your nbconvert and another package require incompatible versions of mistune to one another. You could try to install hopworks first in a new environment and then install the other packages that you need. It may be that both cannot be installed, or that you need versions of each with compatible dependencies.