Error when saving pandas dataframe to feature group

I was trying to save a pandas dataframe into a feature group and I ran into the following error:
TypeError: init() got an unexpected keyword argument ‘validation_type’

I am connecting to the feature store from my local environment using python.

Hi @Ayon,

It looks like a mismatch between the version of the HSFS Python library and the version of Hopsworks. From the error I believe you are using Hopsworks 2.2 but you are still using HSFS 2.1.* - Can you try to update HSFS to 2.2.* and try again?


Thanks @Fabio ,this resolved the issue.
Another issue I am facing is that I am trying to run a job with job type as python. But the job is in the initializing state even after long duration and just doesn’t run.
I even tried a simple python file that just contains the line print(“hello”), but still the same. As I am writing this, the duration is already 14 minutes and still the state is ‘Initializing’.

@Ayon Are you running on

@Fabio Yes, running on

Hi @Ayon
Is the cluster connected to a Kubernetes cluster?

Does it work to start Jupyter in Hopsworks?

@Theo Jupyter doesn’t open up.
Shows the below error:
“Jupyter server could not start.
Timed out waiting for Jupyter pod startup.”

I am using the demo cluster.

Thank you for reporting it, we will have a look and come back shortly


You can try again now, the cluster was running out resources.