Access url for schema registry

Hello there,

i try to connect to the schema registery on from an external producer on my local machine, but i can’t figure out the right url. My code is down below.

schema_registry_conf = {‘url’: “”}
schema_registry_client = SchemaRegistryClient(schema_registry_conf)

It would be nice, if someone can help me there.

Best regards,

Hi @Akil_Guler

You can find an example here Use Python Kafka to interact with Hopsworks - Hopsworks, specifically under the Configuration File and Avro Producer sections. Also please note you will need to modify the accepted header in the schema registry client, as per the instructions under the Avro Producer section.

The url looks correct, excepts it’s missing the leading https://.

Hi @Theo,

thank you for the fast reply. I tried the example but get this error (see picture down below). My toml file looks like:

url = ‘’

verify = false

name = ‘Ameise’
id = ‘119’
ca_file = ‘cert/trustStore.pem’
certificate_file = ‘cert/keyStore.pem’
key_file = ‘cert/keyStore.pem’
key_password = ‘asdf123’

topic = ‘temperatur’
schema = ‘sensor’
port = ‘9092’

group_id = ‘testGroup’
auto_offset_reset = ‘earliest’

base = ‘/hopsworks-api/api’
key = ‘iOHXDWuKYDqnoe2o.k6STdolv4cgHmqIguGkbti5Vsx1e4cyqkjsQNHRI2NG4qFdPHUcFEtEbJvuFx’
key_file = ‘cert/apiKeyFile.txt’

If you find a mistake let me know. Thank you !

Best regards,


The error indicates something wrong with the certificate files, the client does not trust the API server. Did you generate them the same way as shown in the tutorial? Is your Hopsworks cluster using a signed certificate?

Are you instantiating the SchemaRegistry like this?

 schema_registry_conf = {'url': registry_url, '': conf['hops']['verify']}


yes i do it as the same way as shown in the tutorial.

Are you also instantiating the SchemaRegistry client like this?

 schema_registry_conf = {'url': registry_url, '': conf['hops']['verify']}

This will instruct the SchemaRegistry to now verify the https certificate. The stacktrace shows that the SchemaRegistry tires to verify the https connection and fails.

You can also hard-code it like that just to make sure

 schema_registry_conf = {'url': registry_url, '': 'false'}

Also, is your Hopsworks cluster using a signed certificate?

Oh i didn’t checked that, where can i see the option ?

Do you mean about the signed certificate? That is an option when creating the cluster, under the Security Group option in the Create Cluster wizard.

It shouldn’t be required though if the SchemaRegistry is initialized with

I did not specify a security group, while creating a hopsworks cluster and is set to false. I followed the tutorial step by step until this point including the creation the .pem-files.

Can you try removing the option entirely?

Also try setting it to False instead of 'false'

I tried it and it is the same error message nothing changed.

Thanks for the help, i solved the problem now its working ! :slight_smile:

Good to hear that! How did you manage to resolve the problem?

I had to update my cluster, then it was resolved.