Tours Tips: Spark not working

Hi there, After a successful install using vagrant centos 1 VM, 48GB Ram,500GB I was able to log in a start spark tour…or is what I think because was spinning for a long time, afterward the spinning icon back the static and when i click on it again got this message
" Project with the same name already exists.
project: demo_spark_admin000" however is not showing anything in the project search tool, still showing 0 projects.

how can we verify it was created or open the project?


If you login as admin, you can navigate to the admin UI from the top right menu and look under projects management. There you can force remove the project if it’s listed.

But this behavior would indicate that some of the services have not been installed correctly or are down. Which cluster definition did you use to install hopsworks? Which version?

You can also have a look in the app server logs, /srv/hops/domains/domain1/logs/server.log when creating the project as there will probably be a more specific error message.

Thank for the tip Theo, i sorted that out creating a new user and connecting with that account, as hops user was able to create the tour project and resources, not the problem is starting the jupyter server, after click on “jupyterLab” button got a “generic error occured”. following the log you mentioned i found this at then of the file

[#|2020-05-08T18:42:00.003+0000|SEVERE|Payara 4.1|io.hops.hopsworks.common.kafka.ZookeeperTopicCleanerTimer|_ThreadID=85;_ThreadName=__ejb-thread-pool12;_TimeMillis=1588963320003;_LevelValue=1000;| com.logicalclocks.servicediscoverclient.exceptions.ServiceNotFoundException: Error: host not found Could not find service ServiceQuery(name=client.zookeeper.service.consul, tags=[])
** at io.hops.hopsworks.common.kafka.KafkaBrokers.getBrokerEndpoints(**
** at sun.reflect.GeneratedMethodAccessor488.invoke(Unknown Source)**
** at sun.reflect.DelegatingMethodAccessorImpl.invoke(**
** at java.lang.reflect.Method.invoke(**
** at**
** at**
** at com.sun.ejb.containers.BaseContainer.invokeBeanMethod(**
** at com.sun.ejb.EjbInvocation.invokeBeanMethod(**
** at com.sun.ejb.containers.interceptors.AroundInvokeChainImpl.invokeNext(**
** at com.sun.ejb.EjbInvocation.proceed(**
** at org.jboss.weld.ejb.AbstractEJBRequestScopeActivationInterceptor.aroundInvoke(**

My question is if this still provisioning /installing some software?


i just read another threads related with this, so not sure if this screenshot helps but all the services are good.

reviewing things done,noted jupyter project settings has not assigned HIVE and FEATURESTORE, i went a head selecting and the error now is “Could not create HiveDB for project” so back to the admin module and HDFS shows UPGRADE IN PROGRESS
kind of confused if the previous problem may be related with this service not assigned and still pending

if is pending…could it take >3 hrs to upgrade?

How did you install Hopsworks? Did you define allocated 48GB in the vagrant file? Just to check if the installation process was actually completed before starting creating projects, although from the screenshot above with all the services things seem fine

Can you try dig client.zookeeper.service.consul and see if it returns the machine IP?

i used Vagrant(VirtualBox) approach, previous modification of the VM definition for more RAM and Cores

the host is able to reach the service. not the same from the guest host(hopsworks) …it does not have the dig command… would affect any configuration if i install dig command?

Did you use the the script from or from ?
Installation can take 3h, depending on network bandwidth.

you can do yum install bind-utils, it won’t affect the installation.

Does it work if you create an arbitrary, non-tour, project?

followed the instructions from

i ran this : [root@PER420 karamel-chef]# ./ centos 1 hopsworks for the install

i tried what you said and looks like without hive and featureStore works fine.

Thank you, you installed it correctly but this process installs the nightly snapshot build which means things are not as stable as a release build and something might be off in this VM. For example Cannot launch Jupyter notebook

One option would be to restart all services in the VM. vagrant ssh to get a session, then sudo /srv/hops/kagent/kagent/bin/, and then sudo /srv/hops/kagent/kagent/bin/

If that doesn’t help, I would recommend to remove the installation by running ./ from the karamel-chef directory, then git checkout 1.2, increase the memory defined here and then run ./ centos 1 hopsworks as before.

When the installation finishes successfully, you should see a message like “Chef completed successfully” in the nohup.out file.

sounds good, i will try now. thanks a lot for your time. i keep you posted!

1 Like

well after a successful restart and verified the client failed before, this time from the guest VM, all seems to work fine.

jupyter was failing with a weird error so i decided to remove and start over following your guidelines.